vCenter update stuck "Data conversion/Post install hook failed" and how I fixed it

 I was updating a vCenter instance from 7.0 to 7.0.1a but got this error message but everything else seems to work fine. 

I just cleared the install state using this procedure and was able to use VAMI again.

Oddly after clearing the update status VAMI was showing the old build number whereas the vSphere Client shows the new one. 
After some days there was 7.0.1b released and I tried this again but was stuck again at that point.

Just yesterday I tried it again with 7.0.1c but the "Stage" and "Stage and Install" buttons were grayed out. So I digged a little and prepared the VCSA, after that the buttons got clickable again:

Backup your appliance first!

root@vcsa [ /storage/core/software-update ]# mv install_operation install_operation.bak
root@vcsa [ /storage/core/software-update ]# mv stage_install_operation stage_install_operation.bak
root@vcsa [ /storage/core/software-update ]# mv stage_operation stage_operation.bak
root@vcsa [ /storage/core/software-update/updates ]# rm -r *
root@vcsa [ /storage/core/software-update/stage ]# more stageDir.json
{
    "StageDir": "/storage/updatemgr/software-updateced2zkhf/stage"
}
root@vcsa [ /storage/core/software-update/stage ]# rm -r /storage/updatemgr/software-updateced2zkhf/
root@vcsa [ /storage/core/software-update/stage ]# rm stageDir.json
root@vcsa [ /storage/core/software-update/stage ]# service-control --stop applmgmt
root@vcsa [ /storage/core/software-update/stage ]# service-control --start applmgmt


So this somehow cleaned up all remaining states from previous updates.
I decided to use the cli way to install the update via ISO:

Command> software-packages install –iso 

This went through with a hint that some services did not startup in time but it´s retrying. Doing a reboot and waited a little was finally bringing all services up and VAMI and vSphere Client are now showing same update version!

Hope it helps, it´s for sure nothing you should do in a normal scenario!

Comments

Popular posts from this blog

Exception when uploading OVA to vCenter when using Proxy

ESXi Update problem 7.0 to 7.0U1 missing bootbank